I have to admit, im a bit clueless when it comes to the internet. I had ntl before(10 meg) and that was fine, then i moved to china for nine months, and when i came back to luton, i went onto sky, the highest package. In my house we have 3 wireless laptops and an xbox 360. Today i decided to check my speed. My girlfriend was on her laptop, and so was my mum. I done a internet speed test and this was the results. WUGNET

download speed- 878 kbps
upload speed- 299 kbps

I just done the test, and the only other person using the internet is my girlfriend. It just seems very slow.

Router Status

Account Name
Firmware Version V1.02.28

ADSL Port
MAC Address 00:18:4D:60:EE:87
IP Address 90.194.12.196
Network Type PPPoA
IP Subnet Mask 255.255.255.255
Gateway IP Address 82.108.11.90
Domain Name Server 87.86.189.16

LAN Port
MAC Address 00:18:4D:60:EE:86
IP Address 192.168.0.1
DHCP On
IP Subnet Mask 255.255.255.0

Modem
ADSL Firmware Version A2pB018e.d16f
Modem Status Connected
DownStream Connection Speed 1024 kbps
UpStream Connection Speed 768 kbps
VPI 0
VCI 38

Wireless Port
Name (SSID) SKY13699
Region Europe
Channel 1
Wireless AP Enabled
Broadcast Name Enabled

Port Status TxPkts RxPkts Collisions Tx B/s Rx B/s Up Time
WAN PPPoA 37703 67714 0 1002 34028 00:47:14
LAN 10M/100M 1767046 961538 0 6325 173 103:40:48
WLAN 11M/54M 3016745 2506057 0 7105 2160 103:40:38


ADSL Link Downstream Upstream
Connection Speed 1024 kbps 768 kbps
Line Attenuation 59.0 db 31.5 db
Noise Margin 10.1 db 11.0 db

Is this normal?