Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 3 of 3

    Poor picture quality

    This is a discussion on Poor picture quality within the Sky & Sky+ TV forums, part of the Other Sky help and support category; I have recently bought a new Panasonic HD ready 32" LCD TV (with built in Freeview decoder). I get great ...

    1. #1
      KEITERS88's Avatar
      KEITERS88 is offline Sky User Member
      Exchange: 02380
      Broadband ISP: SKY TV
      Router: Non Sky Router
      Sky TV: Sky Basic
      Join Date
      Jun 2009
      Posts
      2
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Poor picture quality

      I have recently bought a new Panasonic HD ready 32" LCD TV (with built in Freeview decoder). I get great picture quality in full 16:9 on Freeview, but the same channels on Sky are poor quality, and in 4:3....
      Anybody know what I'm doing wrong?


    2. Advertisement
    3. #2
      sr1312's Avatar
      sr1312 is offline Sky User Member
      Exchange: Glasgow - Shettleston
      Broadband ISP: Sky Max
      Router: Sagem F@ST 2504
      Sky TV: Sky+ HD
      Join Date
      Jun 2009
      Posts
      32
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Poor picture quality

      Are you viewing sky through scart or RF?

      For best picture use scart and make sure in services - picture on sky box it is set to RGB not PAL , change to 16.9 there too.

      If it's still bad then change the scart lead.

    4. #3
      KEITERS88's Avatar
      KEITERS88 is offline Sky User Member
      Exchange: 02380
      Broadband ISP: SKY TV
      Router: Non Sky Router
      Sky TV: Sky Basic
      Join Date
      Jun 2009
      Posts
      2
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Poor picture quality

      Aspect ration now fine, picture quality still dodgy - must be my cables then........thanks for your help

     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2020. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION