Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 10 of 10
    Like Tree1Likes
    • 1 Post By Isitme

    Firewall rules not working correctly. Any help appreciated

    This is a discussion on Firewall rules not working correctly. Any help appreciated within the Sky Router forums, part of the Sky Broadband help category; Last night I tried to set up my girlfriends Sky router to block internet traffic on a schedule for her ...

    1. #1
      GraemeR71's Avatar
      GraemeR71 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Broadband Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky Basic
      Join Date
      Nov 2015
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      SR102 Firewall rules not working correctly. Any help appreciated

      Last night I tried to set up my girlfriends Sky router to block internet traffic on a schedule for her kids devices. I followed the video guide posted elsewhere on the forums.

      First of all - the kids devices were identified and given a static IP in the range of 192.168.0.30 to 192.168.0.34

      No problems so far.

      Then I set up the schedule from 21.00 to 8am for every day.

      Again, all fine.

      Then I set up the firewall rule - block all ports on schedule for the WAN IP address range above.

      It all looked fine until 21.00 came around and the rule did not kick in.

      I then spent the next hour trying various methods of working around this. Even setting the firewall rule to block everything, all the time instead of on the schedule, didn't seem to make a blind bit of difference.

      I will admit I am stumped. I did wonder if it was something to do with IPV6 as all the IPV6 firewall options were greyed out. Is it possible that the router was blocking IPV4 addresses then assigning everything an IPV6 one and using the default "allow everything" rule? If so, any idea how I can stop it from doing this?

      Or do I just need to give up and go find another router that will allow me to block the little darlings properly? In which case - got any recommendations?
      Last edited by GraemeR71; 16-11-15 at 06:45 PM. Reason: updating title to include router name


    2. Advertisement
    3. #2
      Angel_Rex's Avatar
      Angel_Rex is offline Sky User Member
      Exchange: Uckfield
      Broadband ISP: Zen FTTP
      Router: FRITZ!Box 3490
      Sky TV: Sky Q 2TB
      Join Date
      Jul 2008
      Posts
      604
      Thanks
      70
      Thanked 19 Times in 13 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      I would also like to know this, didn't realise you could even!

    4. #3
      Angel_Rex's Avatar
      Angel_Rex is offline Sky User Member
      Exchange: Uckfield
      Broadband ISP: Zen FTTP
      Router: FRITZ!Box 3490
      Sky TV: Sky Q 2TB
      Join Date
      Jul 2008
      Posts
      604
      Thanks
      70
      Thanked 19 Times in 13 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      Are you blocking inbound and outbound??

    5. #4
      GraemeR71's Avatar
      GraemeR71 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Broadband Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky Basic
      Join Date
      Nov 2015
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      Yeah, nothing I seem to do makes any difference. Starting to suspect that the firewall doesn't work properly on this device as I've come across a few threads asking the same thing with no resolution.

    6. #5
      Scubbie's Avatar
      Scubbie is offline Sky User Moderator
      Exchange: 02392
      Broadband ISP: Other ISP
      Router: Non-Sky Router
      Sky TV: Sky+HD box
      Join Date
      Mar 2010
      Location
      Near Portsmouth
      Posts
      28,249
      Thanks
      848
      Thanked 2,242 Times in 2,105 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      Have you read through any of the guides that we have available on this forum?

      Generally it isn't possible for this to work very well. It's a case that you can block everyone except a specified device, but not a group of devices on the Sky routers.

      PlusNet Fibre since Jan 2021
      Previously Sky Fibre & Sky BB since 2010.

    7. #6
      GraemeR71's Avatar
      GraemeR71 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Broadband Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky Basic
      Join Date
      Nov 2015
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      Quote Originally Posted by Scubbie View Post
      Have you read through any of the guides that we have available on this forum?

      Generally it isn't possible for this to work very well. It's a case that you can block everyone except a specified device, but not a group of devices on the Sky routers.
      Right, thanks. It was actually a video guide on this forum that I followed in the first place. Good to know that the hardware just doesn't work the way its supposed to.

      OK, in that case, on to the second part of my question. Can anyone recommend a router that I can use in place of the SR102 that will work with the Sky broadband and will do what we need?

    8. #7
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,254
      Thanks
      65
      Thanked 1,655 Times in 1,616 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      Then I set up the firewall rule - block all ports on schedule for the WAN IP address range above.
      I take it you mean you blocked the LAN IP range?

      Did you block Outgoing requests?

      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      https://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.





    9. #8
      GraemeR71's Avatar
      GraemeR71 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Broadband Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky Basic
      Join Date
      Nov 2015
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      Quote Originally Posted by Isitme View Post
      I take it you mean you blocked the LAN IP range?

      Did you block Outgoing requests?
      Yes, I created two new firewall rules - block all incoming and outgoing on all ports for the IP address range 192.168.0.30 - 192.168.0.34 on the schedule.

      It didn't make any difference, even when changed to "block all". And yes, I meant the LAN

    10. #9
      Scubbie's Avatar
      Scubbie is offline Sky User Moderator
      Exchange: 02392
      Broadband ISP: Other ISP
      Router: Non-Sky Router
      Sky TV: Sky+HD box
      Join Date
      Mar 2010
      Location
      Near Portsmouth
      Posts
      28,249
      Thanks
      848
      Thanked 2,242 Times in 2,105 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      This might sound daft, but I wonder if this is relocatable to the new firmware that has IPv6 features?

      As an experiment could I ask you to disable IPv6 on the LAN side?

      The link below is from my SR101 and should take you to the correct page. If not it's under Advanced > LAN IP Setup

      http://192.168.0.1/sky_lan_ip_setup.html

      PlusNet Fibre since Jan 2021
      Previously Sky Fibre & Sky BB since 2010.

    11. #10
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,254
      Thanks
      65
      Thanked 1,655 Times in 1,616 Posts

      Re: Firewall rules not working correctly. Any help appreciated

      I have just tried a short experiment blocking all for my PC in the Firewall rules. Admittedly it it was not by Schedule, but there is no reason why it should not work. This was my setup in the Rules -

      Firewall rules not working correctly.  Any help appreciated-capture2.jpg

      One thing to note is that setting up the Rule for IPv4 only did not work, I had to include a rule for IPv6. If you have an IPv6 firewall enabled, you will have to set the rule in this also. Note that this did not appear in the list of rules.
      Scubbie likes this.

      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      https://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.





     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2020. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION