Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 5 of 5

    Using Cisco Router (1941) To Replace Sky Fibre Router

    This is a discussion on Using Cisco Router (1941) To Replace Sky Fibre Router within the Sky Broadband help forums, part of the Sky Broadband help and support category; So after a bit of playing around (and this is likely more a Cisco IOS question), I have managed to ...

    1. #1
      DRCB's Avatar
      DRCB is offline Sky User Member
      Exchange: 01376
      Broadband ISP: Sky Fibre Unlimited
      Router: Cisco 1941 ISR, Aruba 3200XM & AP105.
      Sky TV: Sky Q 2TB
      Join Date
      May 2020
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Using Cisco Router (1941) To Replace Sky Fibre Router

      So after a bit of playing around (and this is likely more a Cisco IOS question), I have managed to get my Cisco 1941 ISR to make a trunk to the SKY cabinet.

      I am showing an active line, and can ping the outside from the router, however client machines inside are unable to hit the internet end, I'm a beginner at these things with a lucky supply of various kit (Yes I know a 1941 ISR is a bit extreme, but its the smallest thing we had for me to play with!).

      So...

      I've got the VDSL connection connection up and running over RJ11 dsl, all good:

      SKY_VDSL#show int ethernet 0/0/0.101
      Ethernet0/0/0.101 is up, line protocol is up
      Hardware is VDSL_ETHERNET, address is REDACTED (REDACTED)
      Description: SKY_VDSL_Trunk
      Internet address is REDACTED
      MTU 1500 bytes, BW 6508 Kbit/sec, DLY 1500 usec,
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1Q Virtual LAN, Vlan ID 101.
      ARP type: ARPA, ARP Timeout 04:00:00
      Keepalive set (10 sec)
      Last clearing of "show interface" counters never




      SKY_VDSL#show int ethernet 0/0/0
      Ethernet0/0/0 is up, line protocol is up
      Hardware is VDSL_ETHERNET, address is REDACTED (REDACTED)
      Description: SKY_VDSL_Physical Interface
      MTU 1500 bytes, BW 6508 Kbit/sec, DLY 1500 usec,
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:29, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue: 0/1024 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
      380 packets input, 25190 bytes, 0 no buffer
      Received 0 broadcasts (0 IP multicasts)
      0 runts, 0 giants, 1 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
      0 input packets with dribble condition detected
      57 packets output, 5607 bytes, 0 underruns
      0 output errors, 0 collisions, 2 interface resets
      0 unknown protocol drops
      0 babbles, 0 late collision, 0 deferred
      0 lost carrier, 0 no carrier
      0 output buffer failures, 0 output buffers swapped out




      SKY_VDSL#ping google.com
      Translating "google.com"...domain server (90.207.238.97) [OK]


      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 172.217.169.46, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms
      SKY_VDSL#

      So from that side, all good. Except my client machines can't ping the internet. Internal IP's etc is all fine. They are getting DHCP provided gateways as the router and valid IP's (as said, internal routing is fine).

      Anyone fancy a peek at this and seeing if they can spot anything blindingly obvious I have missed on the NAT side or the like?

      Current configuration : 3409 bytes
      !
      ! Last configuration change at 16:55:13 UTC Mon May 18 2020
      !
      version 15.7
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname SKY_VDSL
      !
      boot-start-marker
      boot-end-marker
      !
      !
      !
      no aaa new-model
      !
      !
      !
      !
      !
      !
      !
      !
      !
      ip dhcp excluded-address 192.168.0.1 192.168.0.20
      !
      ip dhcp pool DHCP Address Pool
      network 192.168.0.0 255.255.255.0
      default-router 192.168.0.1
      lease 7
      !
      !
      !
      ip cef
      no ipv6 cef
      !
      !
      flow record nbar-appmon
      match ipv4 source address
      match ipv4 destination address
      match application name
      collect interface output
      collect counter bytes
      collect counter packets
      collect timestamp absolute first
      collect timestamp absolute last
      !
      !
      flow monitor application-mon
      cache timeout active 60
      record nbar-appmon
      !
      parameter-map type inspect global
      max-incomplete low 18000
      max-incomplete high 20000
      nbar-classify
      multilink bundle-name authenticated
      !
      !
      !
      license udi pid CISCO1941/K9 sn FCZ185093R3
      !
      !
      object-group service INTERNAL_UTM_SERVICE
      !
      vtp mode transparent
      username REDACTED privilege 15 secret 5 REDACTED
      !
      redundancy
      !
      !
      !
      !
      !
      controller VDSL 0/0/0
      !
      vlan 708-710,901
      !
      !
      class-map type inspect match-any INTERNAL_DOMAIN_FILTER
      match protocol msnmsgr
      match protocol ymsgr
      zone security LAN
      zone security WAN
      zone security VPN
      zone security DMZ
      !
      !
      crypto isakmp policy 1
      !
      !
      !
      !
      !
      !
      !
      !
      !
      interface Embedded-Service-Engine0/0
      no ip address
      shutdown
      !
      interface GigabitEthernet0/0
      no ip address
      shutdown
      duplex auto
      speed auto
      !
      interface GigabitEthernet0/1
      no ip address
      shutdown
      duplex auto
      speed auto
      !
      interface ATM0/0/0
      no ip address
      shutdown
      no atm ilmi-keepalive
      !
      interface Ethernet0/0/0
      description SKY_VDSL_Physical Interface
      mac-address REDACTED
      no ip address
      !
      interface Ethernet0/0/0.101
      description SKY_VDSL_Trunk
      encapsulation dot1Q 101
      ip dhcp client request classless-static-route
      ip dhcp client client-id hex REDACTED
      ip dhcp client hostname REDACTED
      ip address dhcp
      no ip redirects
      no ip unreachables
      no ip proxy-arp
      ip nat outside
      ip virtual-reassembly in
      !
      interface GigabitEthernet0/1/0
      no ip address
      !
      interface GigabitEthernet0/1/1
      no ip address
      !
      interface GigabitEthernet0/1/2
      no ip address
      !
      interface GigabitEthernet0/1/3
      no ip address
      !
      interface GigabitEthernet0/1/4
      no ip address
      !
      interface GigabitEthernet0/1/5
      no ip address
      !
      interface GigabitEthernet0/1/6
      no ip address
      !
      interface GigabitEthernet0/1/7
      no ip address
      !
      interface Vlan1
      description Switchports 0-7
      ip address 192.168.0.1 255.255.255.0
      ip nat inside
      ip virtual-reassembly in
      !
      ip forward-protocol nd
      !
      ip http server
      ip http authentication local
      no ip http secure-server
      ip http timeout-policy idle 60 life 86400 requests 10000
      !
      ip nat inside source list 1 interface Ethernet0/0/0 overload
      ip route 0.0.0.0 0.0.0.0 Ethernet0/0/0
      !
      !
      !
      access-list 1 permit 192.168.0.0 0.0.0.255
      !
      control-plane
      !
      !
      line con 0
      line aux 0
      line 2
      no activation-character
      no exec
      transport preferred none
      transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
      stopbits 1
      line vty 0 4
      login local
      transport input telnet
      !
      scheduler allocate 20000 1000
      event manager applet storePreferences
      event none sync yes
      action 1 file open LOG flash0:ccpexp/preferences.JSON w+
      action 3 file close LOG
      !
      end


    2. Advertisement
    3. #2
      DRCB's Avatar
      DRCB is offline Sky User Member
      Exchange: 01376
      Broadband ISP: Sky Fibre Unlimited
      Router: Cisco 1941 ISR, Aruba 3200XM & AP105.
      Sky TV: Sky Q 2TB
      Join Date
      May 2020
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Using Cisco Router (1941) To Replace Sky Fibre Router

      Answered my own question! NAT was pointing at the physical interface rather than the trunk

      All good now

    4. #3
      det's Avatar
      det
      det is offline Sky User Member
      Exchange:
      Broadband ISP: Sky FTTH
      Router: Edgerouter ERLite-3
      Sky TV: Sky Q
      Join Date
      Aug 2015
      Location
      London
      Posts
      86
      Thanks
      4
      Thanked 10 Times in 10 Posts

      Re: Using Cisco Router (1941) To Replace Sky Fibre Router

      No IPv6?

    5. #4
      DRCB's Avatar
      DRCB is offline Sky User Member
      Exchange: 01376
      Broadband ISP: Sky Fibre Unlimited
      Router: Cisco 1941 ISR, Aruba 3200XM & AP105.
      Sky TV: Sky Q 2TB
      Join Date
      May 2020
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Using Cisco Router (1941) To Replace Sky Fibre Router

      Yeh... not figured that out yet!

    6. #5
      forevergroup's Avatar
      forevergroup is offline Sky User Member
      Exchange: Kidderminster
      Broadband ISP: Wholesale
      Router: Cisco Meraki
      Sky TV: Sky Q 1TB
      Join Date
      Sep 2020
      Posts
      20
      Thanks
      2
      Thanked 2 Times in 2 Posts

      Re: Using Cisco Router (1941) To Replace Sky Fibre Router

      lol clearly a Cisco question rather than a Sky one

      Glad you got it sorted

     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2020. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION