Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 2 of 2

    Cisco 887VA not getting IP address using MER

    This is a discussion on Cisco 887VA not getting IP address using MER within the Sky Broadband (Fibre) Help forums, part of the Sky Broadband help and support category; Hi guys, I am studying for my CCNA and thought it would be useful to replace my SR102 with a ...

    1. #1
      TwoFries's Avatar
      TwoFries is offline Sky User Member
      Exchange: 01403
      Broadband ISP: Please Select
      Router: Cisco 887VA
      Sky TV: Sky+ box
      Join Date
      Oct 2016
      Location
      Horsham
      Posts
      1
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Cisco 887VA not getting IP address using MER

      Hi guys,

      I am studying for my CCNA and thought it would be useful to replace my SR102 with a 887VA router so that I can live with a pure Cisco network at home to get a better understanding of the day to day issues.

      I have used a few of the threads on this forum to build my config but am not able to pick up an IP address from Sky and suspect that it is something simple that I have missed, or an issue with the option 60 & 61 data that I have retrieved using wireshark.

      The VDSL interface seems to come up and sync with no problems but I get the following:

      DHCP debug:

      *Oct 23 08:20:52.416: %CONTROLLER-5-UPDOWN: Controller VDSL 0, changed state to up
      *Oct 23 08:20:54.420: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
      *Oct 23 08:20:54.420: DHCP: DHCP client process started: 10
      *Oct 23 08:20:54.420: RAC: Starting DHCP discover on Ethernet0.101
      *Oct 23 08:20:54.420: DHCP: Try 1 to acquire address for Ethernet0.101
      *Oct 23 08:20:54.420: DHCP: allocate request
      *Oct 23 08:20:54.420: DHCP: new entry. add to queue, interface Ethernet0.101
      *Oct 23 08:20:54.420: DHCP: Client socket is opened
      *Oct 23 08:20:54.420: DHCP: SDiscover attempt # 1 for entry:
      *Oct 23 08:20:54.420: DHCP: SDiscover: sending 360 byte length DHCP packet
      *Oct 23 08:20:54.420: DHCP: SDiscover 360 bytes
      *Oct 23 08:20:54.420: B'cast on Ethernet0.101 interface from 0.0.0.0
      *Oct 23 08:20:55.420: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
      *Oct 23 08:20:57.912: DHCP: SDiscover attempt # 2 for entry:
      *Oct 23 08:20:57.912: DHCP: SDiscover: sending 360 byte length DHCP packet
      *Oct 23 08:20:57.912: DHCP: SDiscover 360 bytes
      *Oct 23 08:20:57.912: B'cast on Ethernet0.101 interface from 0.0.0.0
      *Oct 23 08:21:01.912: DHCP: SDiscover attempt # 3 for entry:
      *Oct 23 08:21:01.912: DHCP: SDiscover: sending 360 byte length DHCP packet
      *Oct 23 08:21:01.912: DHCP: SDiscover 360 bytes
      *Oct 23 08:21:01.912: B'cast on Ethernet0.101 interface from 0.0.0.0%Unknown DHCP problem.. No allocation possible

      Output from show controllers VDSL 0:

      Controller VDSL 0 is UP


      Daemon Status: Up


      XTU-R (DS) XTU-C (US)
      Chip Vendor ID: 'BDCM' 'BDCM'
      Chip Vendor Specific: 0x0000 0xA48C
      Chip Vendor Country: 0xB500 0xB500
      Modem Vendor ID: 'CSCO' ' '
      Modem Vendor Specific: 0x4602 0x0000
      Modem Vendor Country: 0xB500 0x0000
      Serial Number Near: FCZ1943C01E C887VA-K 15.3(3)M6
      Serial Number Far:
      Modem Version Near: 15.3(3)M6
      Modem Version Far: 0xa48c


      Modem Status: TC Sync (Showtime!)
      DSL Config Mode: AUTO
      Trained Mode: G.993.2 (VDSL2) Profile 17a
      TC Mode: PTM
      Selftest Result: 0x00
      DELT configuration: disabled
      DELT state: not running
      Trellis: ON ON
      SRA: disabled disabled
      SRA count: 0 0
      Bit swap: enabled enabled
      Bit swap count: 0 0
      Line Attenuation: 0.0 dB 0.0 dB
      Signal Attenuation: 0.0 dB 0.0 dB
      Noise Margin: 11.6 dB 10.6 dB
      Attainable Rate: 56152 kbits/s 14859 kbits/s
      Actual Power: 13.0 dBm 7.5 dBm
      Per Band Status: D1 D2 D3 U0 U1 U2 U3
      Line Attenuation(dB): 13.3 31.6 49.4 4.8 28.0 43.1 N/A
      Signal Attenuation(dB): 13.3 31.6 49.4 4.8 27.5 43.5 N/A
      Noise Margin(dB): 11.6 11.6 11.6 12.6 10.6 10.4 N/A
      Total FECC: 91 0
      Total ES: 0 0
      Total SES: 0 0
      Total LOSS: 0 0
      Total UAS: 303 303
      Total LPRS: 0 0
      Total LOFS: 0 0
      Total LOLS: 0 0


      Full inits: 1
      Failed full inits: 0
      Short inits: 0
      Failed short inits: 0


      Firmware Source File Name (version)
      -------- ------ -------------------
      VDSL embedded VDSL_LINUX_DEV_01212008 (1)


      Modem FW Version: 130205_1433-4.02L.03.A2pv6C035j.d23j
      Modem PHY Version: A2pv6C035j.d23j
      Vendor Version: Ap6v35j.23j 68




      DS Channel1 DS Channel0 US Channel1 US Channel0
      Speed (kbps): 0 39999 0 9999
      SRA Previous Speed: 0 0 0 0
      Previous Speed: 0 0 0 0
      Reed-Solomon EC: 2 91 0 0
      CRC Errors: 0 0 0 0
      Header Errors: 0 0 0 0
      Interleave (ms): 0.00 0.00 0.00 0.00
      Actual INP: 2.01 48.00 0.00 0.00


      Training Log : Stopped
      Training Log Filename : flash:vdsllog.bin

      Here is my current config:

      version 15.3
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname Home_GW
      !
      boot-start-marker
      boot-end-marker
      !
      aqm-register-fnf
      !
      enable password ********
      !
      no aaa new-model
      !
      !
      !
      !
      !
      !
      !
      ip dhcp excluded-address 172.16.50.1 172.16.50.99
      ip dhcp excluded-address 172.16.50.201 172.16.50.254
      !
      ip dhcp pool HOME
      domain-name home.local
      dns-server 8.8.8.8
      default-router 172.16.50.250
      network 172.16.50.0 255.255.255.0
      !
      !
      !
      no ip domain lookup
      ip cef
      no ipv6 cef
      !
      !
      !
      !
      !
      multilink bundle-name authenticated
      !
      !
      !
      !
      !
      !
      !
      license udi pid C887VA-K9 sn FCZ1943C01E
      !
      !
      !
      !
      !
      !
      !
      controller VDSL 0
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      !
      interface ATM0
      no ip address
      shutdown
      no atm ilmi-keepalive
      !
      interface Ethernet0
      mac-address ****.****.****
      no ip address
      !
      interface Ethernet0.101
      encapsulation dot1Q 101
      ip dhcp client request classless-static-route
      ip dhcp client class-id hex ************************************************** ***************************
      ip dhcp client hostname ************@skydsl|********
      ip address dhcp
      no ip redirects
      no ip proxy-arp
      ip flow ingress
      ip flow egress
      ip nat outside
      no ip virtual-reassembly in
      !
      interface FastEthernet0
      no ip address
      !
      interface FastEthernet1
      no ip address
      !
      interface FastEthernet2
      no ip address
      !
      interface FastEthernet3
      no ip address
      !
      interface Vlan1
      ip address 172.16.50.250 255.255.255.0
      ip flow ingress
      ip flow egress
      ip nat inside
      ip virtual-reassembly in
      !
      ip forward-protocol nd
      no ip http server
      no ip http secure-server
      !
      !
      ip nat inside source list NATACL interface Ethernet0.101 overload
      !
      ip access-list standard NATACL
      permit 172.16.50.0 0.0.0.255
      !
      dialer-list 1 protocol ip permit
      !
      !
      control-plane
      !
      !
      !
      mgcp behavior rsip-range tgcp-only
      mgcp behavior comedia-role none
      mgcp behavior comedia-check-media-src disable
      mgcp behavior comedia-sdp-force disable
      !
      mgcp profile default
      !
      !
      !
      !
      !
      line con 0
      logging synchronous
      no modem enable
      line aux 0
      line vty 0 4
      password ********
      login
      transport input all
      line vty 5 189
      password ********
      login
      transport input all
      !
      scheduler allocate 20000 1000
      !
      end

      Any help or comments greatly appreciated


    2. Advertisement
    3. #2
      det's Avatar
      det
      det is offline Sky User Member
      Exchange:
      Broadband ISP: Sky FTTH
      Router: Edgerouter ERLite-3
      Sky TV: Sky Q
      Join Date
      Aug 2015
      Location
      London
      Posts
      86
      Thanks
      4
      Thanked 10 Times in 10 Posts

      Re: Cisco 887VA not getting IP address using MER

      I don't remember the cli syntax, but the value you're setting in "ipdhcp client hostname ************@skydsl|********"
      should be set as the client-identifier instead.

     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2020. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION