Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Page 2 of 2 FirstFirst 12
    Results 11 to 19 of 19

    sky router won't give my pc an ip address

    This is a discussion on sky router won't give my pc an ip address within the Sky Router forums, part of the Sky Broadband help category; What was it on before you disabled it? WEP or WPA?...

    1. #11
      PaulSky's Avatar
      PaulSky is offline Sky User Member
      Exchange:
      Broadband ISP: Max
      Router: Netgear V1 DG834GT
      Sky TV: Sky Basic
      Join Date
      Sep 2007
      Location
      Essex
      Posts
      4,202
      Thanks
      0
      Thanked 16 Times in 16 Posts

      Re: sky router won't give my pc an ip address

      What was it on before you disabled it? WEP or WPA?


    2. Advertisement
    3. #12
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,131
      Thanks
      64
      Thanked 1,641 Times in 1,602 Posts

      Re: sky router won't give my pc an ip address

      That's good. Now you will have to enter the pass word/key into the laptops connection manager. If you go back to the router wireless settings and make a note of the type of security being used, the default is WPA-PSK and the default key is all capital letters, if it has not been changed. When you have done that re-enable the security. You will loose your connection to the router.
      Now click the wireless Icon in the System Tray at the bottom right of the screen and select 'Let Windows Managed my Connection' if this is not already selected. If it is already selected it will not be shown. Now click 'View available networks' and a box will come up wherein you can select the SkyXXXX SSID and put in the pass word. Save and close out and you should be able to connect.

      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      http://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.





    4. #13
      matt_39's Avatar
      matt_39 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Connect
      Router: Netgear V1 DG834GT
      Sky TV: Sky Basic
      Join Date
      Nov 2008
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: sky router won't give my pc an ip address

      ok, latest update:

      I logged back into the router, turned WPA-PSK back on, lost my connection. I changed the connections back to the passkey on the router and had the same old problem of a very unstabe connection. I then logged back in to change it to WEP to see if that made any difference but when I clicked the radio button it seeemed to change the settings immediately, without allowing me to set up the security settings, breaking the connection. I was able to get back in and change it back to WPA (the router page must have been in the cache or something?) but the damage was done and consequently the sky wireless network no longer appears in 'Select a network to connect to'.

      This has happened on both my laptop which originally had the fault (XP) and my flatmate's which I had been using to fix it (Vista) but doesnt seem to have affected either the other Windows laptops in the house, a Macbook or a g3 phone, which are all working fine.

      What on earth is going on?!

      ps the ethernet connection is still a-ok, hence my posting of this message.

    5. #14
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,131
      Thanks
      64
      Thanked 1,641 Times in 1,602 Posts

      Re: sky router won't give my pc an ip address

      Sorry, I should have made it clear you should use an ethernet connection to make the changes.
      The problem is that if the security is set to WPA and you change it to WEP the machines that were able to connect will no longer be able to do so. Does your installation of XP include Sp1 with the 815485 Update? If you have Sp2 or higher it will be included. Have a look at THIS which explains how to connect under this heading Configure WPA-PSK on Windows XP



      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      http://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.





    6. #15
      matt_39's Avatar
      matt_39 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Connect
      Router: Netgear V1 DG834GT
      Sky TV: Sky Basic
      Join Date
      Nov 2008
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: sky router won't give my pc an ip address

      Yeah, I wasn't really thinking when I did that.

      I think the more pressing concern now is that the wireless network doesn't show up on my flatmate's laptop at all anymore (it appears on mine, I just can't connect to it). Although it's a problem with the computer itself, not the router (I spent an hour on the phone to sky to confirm this...) can you offer any advice? The wireless adaptors et al are working correctly, apart from ISATAP #5 but apparently that's just how it looks on Vista SP1. The firewall is turned off.

    7. #16
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,131
      Thanks
      64
      Thanked 1,641 Times in 1,602 Posts

      Re: sky router won't give my pc an ip address

      In the Vista machine, open the Network and sharing Centre. The easiest way to do this is to press the Windows key and type 'Network' and it will appear in a list above, click it to open.

      The first thing to do is disable IPv6, which is not required and can cause problems. To do this click 'Manage network connections'. Right click the icon for an adapter and choose Properties. Untick the entry for Internet Protocol Ver 6(TCP/IPv6) and click OK. Do this with both adapters.
      Now go back to the Network Centre and check that Network Discovery is ON. If it is not, click the down arrow and select it. If this was not ON the Network would not be detected, so this in itself will cure the problem. Unless your friend is sharing files on the network, everything else should be OFF.

      If this does not fix it post back.

      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      http://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.





    8. #17
      matt_39's Avatar
      matt_39 is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Connect
      Router: Netgear V1 DG834GT
      Sky TV: Sky Basic
      Join Date
      Nov 2008
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: sky router won't give my pc an ip address

      Quote Originally Posted by Isitme View Post
      In the Vista machine, open the Network and sharing Centre. The easiest way to do this is to press the Windows key and type 'Network' and it will appear in a list above, click it to open.

      The first thing to do is disable IPv6, which is not required and can cause problems. To do this click 'Manage network connections'. Right click the icon for an adapter and choose Properties. Untick the entry for Internet Protocol Ver 6(TCP/IPv6) and click OK. Do this with both adapters.
      Now go back to the Network Centre and check that Network Discovery is ON. If it is not, click the down arrow and select it. If this was not ON the Network would not be detected, so this in itself will cure the problem. Unless your friend is sharing files on the network, everything else should be OFF.

      If this does not fix it post back.
      Ok so I disabled IPv6, then went to check network discovery which I found was ON. The sky network still doesn't appear on the list though. What should I try next? Thank god they're still making computers with ethernet ports...

    9. #18
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,131
      Thanks
      64
      Thanked 1,641 Times in 1,602 Posts

      Re: sky router won't give my pc an ip address

      Were both adapters, ethernet and wireless, shown in the Network? If so, check in the Router for the following under Wireless Access Point. Enable Wireless Access Point Allow Broadcast of Name (SSID)Make sure both are ticked, if either are not, tick and try to connect by wireless. While you are there check that the Wireless Station Access list is not turned on. Remember to disconnect ethernet first. If still no joy -leave ethernet off -
      Now click 'Connect to a Network' in the left pane of the Network and Sharing Centre. A pane will open and show if you are connected or not. If you are not connected click the 'Set up a connection' link at the bottom, then 'Connect to the Internet' in the next page. Follow the Wizard. If it says you are connected click the 'Diagnose why Windows can't find any additional networks' and again follow the instructions. This should find the Wireless adapter and instruct you what to do.
      To be honest I am baffled as to why changing the security then changing it back again should have caused this problem. I am constantly changing the Security in my router to fix other peoples PCs and never have this problem.

      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      http://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.





    10. #19
      chrisstevens's Avatar
      chrisstevens is offline Sky User Member
      Exchange:
      Broadband ISP: Connect
      Router:
      Sky TV:
      Join Date
      Dec 2007
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: sky router won't give my pc an ip address

      I'm having the exact same issues since the upgrade to the 1.9 firmware(I'm using a sagem).
      I still havent found a resolution however if you change the channel, Vista will then find the ssid for a period f time until you need to change it again.

     

     
    Page 2 of 2 FirstFirst 12

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION