Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Page 1 of 3 123 LastLast
    Results 1 to 10 of 24

    Setting up Home Web Server with Sky Broadband

    This is a discussion on Setting up Home Web Server with Sky Broadband within the Sky Broadband help forums, part of the Sky Broadband help and support category; Hi, I was wondering whether anyone could shed some light on setting up a Home Web Server with Sky Boradband. ...

    1. #1
      Indigo's Avatar
      Indigo is offline Sky User Member
      Exchange:
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Jan 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Setting up Home Web Server with Sky Broadband

      Hi,

      I was wondering whether anyone could shed some light on setting up a Home Web Server with Sky Boradband. I used to have a Home Web Server working fine with my old ISP (Freedom2Surf) and old Drayetk router but since switching to Sky Boradband I seem to be having difficulties.

      Using the Sky Netgear router I have opened up Port 80 for HTTP and setup a DynDNS service for my personal domain but only receive the Sky Router's admin logon page when I try to view my home website.

      Is there anything else I need to do perhaps?

      Thanks in anticipation


    2. Advertisement
    3. #2
      speedcheese's Avatar
      speedcheese is offline Sky User Member
      Exchange:
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Nov 2006
      Posts
      12
      Thanks
      0
      Thanked 0 Times in 0 Posts
      Two things to try:

      1. Make sure you've got port 80 forwarded to the correct IP address in your router. You may also want to reserve the same IP address if you're using DHCP to avoid having to reassign the rule if you bounce your router for any reason.

      2. Change the management port for the router. I think it's under the "Remote Management" section.

      As a final check, try setting your web server to listen on another port than 80 and open that port up too. Then enter http://blahblah.dyndns.org:8081 for example and see if that works.

      FWIW, I've had a web server running for weeks now with no problems.

    4. #3
      Keiran2K8's Avatar
      Keiran2K8 is offline Skyuser Serial Spammer
      Exchange: Redditch
      Broadband ISP: Max & VM VIP-85 & Be* Pro
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Oct 2006
      Location
      Redditch, WestMidlands, England, UK
      Posts
      3,763
      Thanks
      0
      Thanked 1 Time in 1 Post
      Blog Entries
      3
      Just a heads, Up!

      You CANNOT access your webserver from the host computer via the external IP e.g 86.22.xx.xx

      Internally e.g. On your LAN you can access the site via the Local Host page only!
      Or the local host IP : 127.0.0.1


      People from outside your routers network have to access it via the external IP e.g 86.22.xx.xx!

    5. #4
      Nutter's Avatar
      Nutter is offline Sky User Member
      Exchange: Basingstoke
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Sep 2006
      Posts
      80
      Thanks
      0
      Thanked 0 Times in 0 Posts
      You may have to add an entry into your local host file.
      as the IP address that is assigned to your router is not the location of your website.
      You will need to add an entry for your domain name to reflect the ip address of your webserver, i.e your.domain.name.com 192.168.0.X

      Check it first by browsing to the ip address assigned to your webserver
      If that works but by name doesnt add the entry to your hosts file.

      Ive had a webserver running on my linux box, for years now, and got it running on the sky service in minutes, when I got that installed in Nov 2006


      HTH
      Nutter
      There are 10 people who understand binary, Those that do and those that dont

    6. #5
      Indigo's Avatar
      Indigo is offline Sky User Member
      Exchange:
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Jan 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Thanks for replying guys.

      Can I just verify that all one needs to do is to setup an 'HTTP on Port 80' Inbound Service via the Firewall Rules router option and that this rule be sent to the desired WAN server, i.e. in this case the actual Web server?

      The reason I ask is because even if I type in the external IP address of the router I still get the router's admin login window as opposed to the web site running on my internal LAN webserver....

    7. #6
      NewsreadeR's Avatar
      NewsreadeR is offline Site Founder
      Exchange: Marshalls Cross
      Broadband ISP: Sky Broadband Unlimited
      Router: Sagem F@ST 2504n
      Sky TV: Sky+HD box
      Join Date
      Aug 2006
      Location
      St Helens
      Posts
      22,211
      Thanks
      108
      Thanked 373 Times in 304 Posts
      Blog Entries
      48
      Can I just verify that all one needs to do is to setup an 'HTTP on Port 80' Inbound Service via the Firewall Rules router option and that this rule be sent to the desired WAN server, i.e. in this case the actual Web server?
      Yes so if your PC IP is 192.168.0.2 you would forward to that

      The reason I ask is because even if I type in the external IP address of the router I still get the router's admin login window as opposed to the web site running on my internal LAN webserver
      Set it up now and I will test for you externally, you should not be able to see the website locally, unless you use 127.0.0.1 in your browser.

      Post when you have forwarded it and the server is running.




      ~ Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience ~

      Follow us on Twitter @skyuser

    8. #7
      Keiran2K8's Avatar
      Keiran2K8 is offline Skyuser Serial Spammer
      Exchange: Redditch
      Broadband ISP: Max & VM VIP-85 & Be* Pro
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Oct 2006
      Location
      Redditch, WestMidlands, England, UK
      Posts
      3,763
      Thanks
      0
      Thanked 1 Time in 1 Post
      Blog Entries
      3
      The reason I ask is because even if I type in the external IP address of the router I still get the router's admin login window as opposed to the web site running on my internal LAN webserver....
      YOU can only access your HTTP server INTERNALLY via http://locahost or Default PLESK Page

      Only people like me out of your LAN can access your HTTP Server via the external IP

    9. #8
      Indigo's Avatar
      Indigo is offline Sky User Member
      Exchange:
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Jan 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Hi guys,

      My webserver is running on a laptop using Internet Information Services (IIS) on Windows 2000 Advanced Server and as such a hosts file is not needed. One assigns the internal ip address of the laptop/webserver to the Host Header Name of the web site via IIS.

      Now, the web site works fine locally on the laptop when I remove the local ip address/Host Header Name association in IIS, i.e. I can browse the web site fine locally on the laptop - as expected.

      However, when I add the local ip address/Host Header Name assocaiation via IIS, I am unable to view the web site locally - as expected. Instead I receive the router login prompt. This according to FibreOptic is to be expected as one cannot view the web site via it's external ip address locally.

      I have even tried viewing my web site from my work place (i.e. external to my router's network) but still keep receiving the router's login prompt instead of my web site.

      I guess there must still be something wrong with my router settings eventhough I have setup an 'HTTP on Port 80' Inbound Service via the Firewall Rules router option and routed it through to the ip address of my laptop running my webserver. Am I still missing something here?

      Can any of you guys try visiting the following site:

      SaakiBains.com > Home


      Thanks in advance,

    10. #9
      NewsreadeR's Avatar
      NewsreadeR is offline Site Founder
      Exchange: Marshalls Cross
      Broadband ISP: Sky Broadband Unlimited
      Router: Sagem F@ST 2504n
      Sky TV: Sky+HD box
      Join Date
      Aug 2006
      Location
      St Helens
      Posts
      22,211
      Thanks
      108
      Thanked 373 Times in 304 Posts
      Blog Entries
      48
      Welcome to SaakiBains.com


      Site Objectives:
      This site is primarily geared towards presenting my skills and achievements as a Microsoft® Certified Software Consultant/Analyst Programmer.
      Works fine, however a little slow, but it could be my connection.




      ~ Never, ever, argue with an idiot. They'll drag you down to their level and beat you with experience ~

      Follow us on Twitter @skyuser

    11. #10
      Disillusioned's Avatar
      Disillusioned is offline Sky User Member
      Exchange: SSFLT Filton Bristol
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Dec 2006
      Location
      North Bristol
      Posts
      183
      Thanks
      0
      Thanked 0 Times in 0 Posts
      I accessed it okay too. Speed was ok for me
      ~Computing today is a race between software engineers striving to build bigger and better idiot-proof programs and the universe trying to produce bigger and better idiots. So far, the universe is winning~

     

     
    Page 1 of 3 123 LastLast

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION