Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 3 of 3

    Is Installing Java (TM) Plug In A Security Problem?

    This is a discussion on Is Installing Java (TM) Plug In A Security Problem? within the Sky Broadband help forums, part of the Sky Broadband help and support category; I play on Pogo.com using Safari but since I upgraded my Mac from Mountain Lion to Maverick, I have found ...

    1. #1
      wolfiebrian's Avatar
      wolfiebrian is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Broadband Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky Basic
      Join Date
      Nov 2012
      Posts
      97
      Thanks
      13
      Thanked 0 Times in 0 Posts

      Is Installing Java (TM) Plug In A Security Problem?

      I play on Pogo.com using Safari but since I upgraded my Mac from Mountain Lion to Maverick, I have found that I cannot play Pogo because I haven't got the Java TM plug in.

      I have read that having Java installed can be a security threat

      Before I kept getting boxes up when I chose a game asking me to allow permissions for the game to run, which I guess could allow the doors open for backdoor security risks?

      I get this error message now when I try to load any Pogo game. The site loads, but the games don't.

      Your browser couldnít load this Java game.

      Pogo requires the latest version of Java to be running on your Machine. Please visit Java.com to download the latest version.
      Update Java
      Update didnít work?
      Check out Java.comís TestJava page.
      Check out our Troubleshooting page on enabling Java in your browser.
      Still experiencing issues? Check out Oracle's Java and Pogo Troubleshooting Guide.


    2. Advertisement
    3. #2
      Scubbie's Avatar
      Scubbie is offline Sky User Moderator
      Exchange: 02392
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Q Hub ER110
      Sky TV: Sky+HD box
      Join Date
      Mar 2010
      Location
      Near Portsmouth
      Posts
      27,908
      Thanks
      812
      Thanked 2,195 Times in 2,065 Posts

      Re: Is Installing Java (TM) Plug In A Security Problem?

      There was an issue with a version of Java last year but this was fixed.

      There is always a risk that thee is some exploit which could be taken advantage of. Just look at Open SSL and the reported issues recently.

      Basically for those who are paranoid just connecting a device to the Internet would be a security risk.

      Be careful though. Here are fake plug-ins on some websites. If you are visiting a site and it insists that you update any plug-in check with the corresponding site first.

      Sky Fibre Unlimited Pro: Connected at 80,000 kbps / 20,000 kbps
      Previous ADSL2+ Speed 19999 kbps 1153 kbps, Line Attenuation 17.5 db 6.9 db, Noise Margin 7.5 dB 8.7 dB
      Speedtest: 17.15MB/s 0.97Mb/s Ping 31 ms

    4. #3
      seawright's Avatar
      seawright is online now Sky User Member
      Exchange: 02392
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Sky+HD box
      Join Date
      Jul 2012
      Posts
      3,193
      Thanks
      63
      Thanked 337 Times in 328 Posts

      Re: Is Installing Java (TM) Plug In A Security Problem?

      If Java 7u55 is the latest version available from java.com you may require Java SE 8 which is available from oracle.com.
      Check out: Java SE | Oracle Technology Network | Oracle

     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION