Check on your DD-WRT router to see if either DHCP or Wireless Isolation is enabled. Both should be disabled.