Have you done what i said yet ?

Also try changing the power management for the wireless device ?

If not try that ,

Start ----- Control Panel ----- System ----- Device manager ----- Right click on the device you want to change ----- Properties ----- power management

Then remove the tick from allow the computer to turn off this device to save power !

Screen shots :

Hope this helps ,