Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 63k members.


    Results 1 to 4 of 4

    Problems with internet connection

    This is a discussion on Problems with internet connection within the Sky Broadband help forums, part of the Sky Broadband help and support category; I'm helping an old friend who just got a new sky package, including internet etc. The problem I have is ...

    1. #1
      noway's Avatar
      noway is offline Sky User Member
      Broadband ISP: Connect
      Router: Netgear V1 DG834GT
      Sky TV:
      Join Date
      Mar 2008
      Thanked 0 Times in 0 Posts

      Problems with internet connection

      I'm helping an old friend who just got a new sky package, including internet etc. The problem I have is that the new sky router when the internet green light comes on and try to get into internet it shows on the screen that I am not connected. Much later sudenly I can connect to internet, why is this happening ? Is there anything in my computer interferring ? I tried to remove some programmes from the Add/Remove in control panel but still does not solve the internet connection problem. Got AVG antivirus and some expired Norton do you think this later interferes? When I open the computer it comes through internet explorer the sky internet but is frustraing when it appears the wording "you are not connected", please gives some help otherwise will have to return Sky package.

    2. Advertisement
    3. #2
      dms05's Avatar
      dms05 is offline Sky User Beta tester
      Exchange: 0151
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Other
      Join Date
      Dec 2007
      Thanked 52 Times in 50 Posts

      Re: Problems with internet connection

      If the Router has a firm and stable green Internet light showing then your problem probably lies with the computer. My experience of installing the Sky router is it works straight from the box.

      I'm assuming you have connected your router to the PC with a LAN cable and not by WiFi. If you are using WiFi change to the LAN method.

      You will also need to make sure the Network Card in your PC is enabled.

      Finally do you have a Firewall installed (other than the Windows one). If you do then select and disable it from it's software.

      In your browser (I assume IE7) type this connects you directly to the router and will work with or without the Internet been connected. This should open the router set up page. If it doesn't you will have to work out why it isn't working - and that will not be a router problem but a problem with your computer or LAN cable.

      If it does open the go back to your Firewall and enable it again. Does the Router still connect to If it doesn't then it's the Firewall causing the problem.

      It's a matter of working through all the possible problems on your PC.

    4. #3
      PaulSky's Avatar
      PaulSky is offline Sky User Member
      Broadband ISP: Max
      Router: Netgear V1 DG834GT
      Sky TV: Sky Basic
      Join Date
      Sep 2007
      Thanked 16 Times in 16 Posts

      Re: Problems with internet connection

      Expired nortons? well that would be my first removal to be honest, from what you have said in your post you seem to be blaming sky for something that may not be their fault. If we can get some info from you we may be able to help more.

    5. #4
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Broadband Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Central Scotland
      Thanked 1,624 Times in 1,586 Posts

      Re: Problems with internet connection

      I agree with Paul, the first thing to do is get rid of Norton. To do this, go HERE , download the cleanup tool and run it on the PC.

      Did you install McAfee when you ran the CD? If you did get rid of it too, it can be configured, but in my opinion is not worth the bother. If you have the latest version of AVG7 that is more than enough.

      Go to the router set up page and check if you are being allocated an IP address. Click the Statistics link and post the results.

      Another thing you can try is downloading and running WinSockRepair There is a chance that you have removed something that is required for the connection.


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.

      Useful Utilites

      Inssider 2/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.



    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    SkyUser - Copyright © 2006-2014. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB