Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Page 3 of 3 FirstFirst 123
    Results 21 to 29 of 29

    VoIP with Sky/Sagem F@st 2504

    This is a discussion on VoIP with Sky/Sagem F@st 2504 within the Sky Broadband help forums, part of the Sky Broadband help and support category; Then a dodgy router or firmware would seem to be the problem. As you say, phone Sky, hopefully you will ...

    1. #21
      Isitme's Avatar
      Isitme is offline Sky User Moderator
      Exchange: Bannockburn
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Sky+ HD
      Join Date
      Dec 2006
      Location
      Central Scotland
      Posts
      34,131
      Thanks
      64
      Thanked 1,641 Times in 1,602 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      Then a dodgy router or firmware would seem to be the problem. As you say, phone Sky, hopefully you will get an understanding operator.

      TomD


      Please note the views and recommendations in my posts are my own and in no way reflect the views of SkyUser.


      Useful Utilites

      http://www.nirsoft.net/utils/wifi_information_view.html/ TCPOptimiser /Test Socket

      Note - When downloading always select the Custom install or you will end up with stuff you don't want.






    2. Advertisement
    3. #22
      Jak-S's Avatar
      Jak-S is offline Sky User Member
      Exchange: Kemptown
      Broadband ISP: Max
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Apr 2008
      Posts
      13
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      @Ashe:

      Hey, did you ever have any luck getting SIP working on the Sagem router? I've just got our connection up and running, but no matter what I try I can't get a connection on SIP/port 5060. I've tried forwarding all the ports, and forwarding the specific ports my VOIP provider (sipgate) lists, but with no luck. Luckily I'm not relying on this VOIP line, but would like to be able to use SIP properly fairly soon.

      Do you think this is a technical problem with the router, or do you think Sky have actually blocked that port deliberately?

    4. #23
      Ashe's Avatar
      Ashe is offline Sky User Member
      Exchange: Bradwell Abbey (SMBA)
      Broadband ISP: Sky Fibre Unlimited
      Router: Sagem F@ST 2504n
      Sky TV:
      Join Date
      Dec 2007
      Location
      Milton Keynes
      Posts
      15
      Thanks
      1
      Thanked 0 Times in 0 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      Quote Originally Posted by Jak-S View Post
      Hey, did you ever have any luck getting SIP working on the Sagem router?
      No, unfortunately I haven't had any luck yet. But I can confirm that the problem is definitively caused by the Sagem F@st 2504.

      Quote Originally Posted by Jak-S View Post
      I've just got our connection up and running, but no matter what I try I can't get a connection on SIP/port 5060. I've tried forwarding all the ports, and forwarding the specific ports my VOIP provider (sipgate) lists, but with no luck. Luckily I'm not relying on this VOIP line, but would like to be able to use SIP properly fairly soon.
      As I already stated I'm quite sure that the problem is actually caused by the SIP proxy function of the router. So it doesn't matter whether you open ports in the firewall or forward ports to a specific IP. As long as your router intercepts all TCP packets destined for port 5060 and screws up when it processes these packets you won't be able to use SIP. There is only one workaround: find a SIP provider/SIP client which is configured to accept/send SIP request at TCP ports != 5060.

      Quote Originally Posted by Jak-S View Post
      Do you think this is a technical problem with the router, or do you think Sky have actually blocked that port deliberately?
      This issue is a technical problem of the router. Sky does NOT block port TCP 5060.
      As my VoIP router AVM Fritz!Box is an Annex B box I need a device to adapt to the Annex A DSL you find here in the UK. So far, that was done by the Sagem router. Recently I bought an ADSL/Ethernet modem and exchanged it with the Sagem router in my topology for testing purposes. Result: SIP works fine without the Sagem router. Because this is against the Sky T&C I'd prefer a solution with a Sky router (whatever model) in front of my AVM VoIP router.

      How do I get Sky to exchange my Sagem F@st 2504 with a (hopefully) working model like the Netgear DG934G?

    5. #24
      skytzo's Avatar
      skytzo is offline Sky User Member
      Exchange:
      Broadband ISP: Mid
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Aug 2008
      Posts
      11
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Unhappy Re: VoIP with Sky/Sagem F@st 2504

      Did any of you manage to find a resolution to this? I have the exact same problem, with some twists that might help:

      * A hard reset of the router returns X-Lite to a working state and X-Lite will always connect fine through port 5060.
      * If I however try to connect from my Nokia Eseries VoIP phone, it throws the router into a non-functional state as far as VoIP is concerned. X-Lite will then never connect again.
      * Another hard reboot and X-Lite works fine, until I try to connect from the Nokia.
      * I have tried WEP as suggested instead of WPA but it makes no difference.

      Was there ever a resolution to this?

    6. #25
      skytzo's Avatar
      skytzo is offline Sky User Member
      Exchange:
      Broadband ISP: Mid
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Aug 2008
      Posts
      11
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Question Re: VoIP with Sky/Sagem F@st 2504

      Quote Originally Posted by Ashe View Post
      You need to circumvent the proxy function by using another port for SIP. You need an SIP registrar listening on that port too. And last but not least you have to open a whole port range for RTP, because the router wouldn't be able to figure out anymore, which specific ports are negotiated for RTP.
      My SIP provider (Voipfone) does work on other ports when I tried with a Linksys router, e.g. 5075, but not via Sky. Can you please advise exact how to perform the RTP port opening you mentioned above so as to allow VoIP through my SIP device via the Sky router on port 5075?

    7. #26
      Ashe's Avatar
      Ashe is offline Sky User Member
      Exchange: Bradwell Abbey (SMBA)
      Broadband ISP: Sky Fibre Unlimited
      Router: Sagem F@ST 2504n
      Sky TV:
      Join Date
      Dec 2007
      Location
      Milton Keynes
      Posts
      15
      Thanks
      1
      Thanked 0 Times in 0 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      Hello,

      Quote Originally Posted by skytzo View Post
      Did any of you manage to find a resolution to this? I have the exact same problem, with some twists that might help:

      * A hard reset of the router returns X-Lite to a working state and X-Lite will always connect fine through port 5060.
      * If I however try to connect from my Nokia Eseries VoIP phone, it throws the router into a non-functional state as far as VoIP is concerned. X-Lite will then never connect again.
      * Another hard reboot and X-Lite works fine, until I try to connect from the Nokia.
      * I have tried WEP as suggested instead of WPA but it makes no difference.

      Was there ever a resolution to this?
      Yes, there has been a resolution to this issue. After my Sagem F@st 2504 box recently screwed up completely (the router firewall blocked all incoming connections regardless of configuration) I asked the Sky support for a replacement. I got a new Netgear DG834GT within a few days. Since then I haven't had any problems with SIP. Apparently, my SIP issue was caused by a faulty router.

      Quote Originally Posted by skytzo View Post
      My SIP provider (Voipfone) does work on other ports when I tried with a Linksys router, e.g. 5075, but not via Sky. Can you please advise exact how to perform the RTP port opening you mentioned above so as to allow VoIP through my SIP device via the Sky router on port 5075?
      Please follow the guides in this forum to open a port from the outside. According to http://en.wikipedia.org/wiki/Real-ti...sport_Protocol RTP is generally configured to use ports 16384-32767. Therefore you have to use 16384 as start port and 32767 as finish port as well type: UDP in den "Services" -> "Add custom service" dialog.

      But I have to advise against opening a 16K port range your firewall. That's a quite huge hole you'd drill in your firewall. The best way for using SIP (in regard to security) is to rely on the SIP proxy function of a SIP aware router. When you're experiencing SIP problems with your Sky router try to get a replacement router. The F@st 2504 is SIP aware. So, SIP problems are likely to be caused my a malfunctioning router.

    8. #27
      skytzo's Avatar
      skytzo is offline Sky User Member
      Exchange:
      Broadband ISP: Mid
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Aug 2008
      Posts
      11
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      Thanks for the info. After half an hour on the phone to $ky I have managed to persuade a Supervisor to send me a new router. Quoted time is 3-5 days. I have asked them to put a request on the notes for the Netgear.

      My only question is if they send the Sagem, presumably I will still have the problem as I am not 100% convinced it is a 'fault' - most of the early comments in this thread implied it was a design flaw?

      If I do end up with another Sagem and the problem with port 5060 remains, I will get a Netgear off eBay. Should I go for the white one or the new shape black one?
      Thanks!

      Sky-tzo

      Recommended:
      * http://search.superhighstreet.com - Finds anything or they pay!
      * http://www.superhighstreet.com & http://www.oxfordstreet.com - Beat the crowds with Virtual Streetscapes

    9. #28
      madkat's Avatar
      madkat is offline Sky User Member
      Exchange: 01246
      Broadband ISP: Mid
      Router: Sagem F@ST 2504
      Sky TV:
      Join Date
      Jul 2008
      Posts
      1
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      I had a brainwave.
      And I can't believe nobody else thought of it.
      Seriously.

      It occurred to me that the router configuration file is just a .conf file. Now these are usually plain text. In this case, it's XML.

      I opened the .conf file in Notepad++. You can use any editor you want.

      I was scanning through the various elements when I spotted a property called siproxd. WTF? What's that? It has "SIP" and "prox" in the name... Google came up with this: Siproxd Project

      So I changed the value from "enable" to "disable", saved the conf file and reimported it into the router.

      BINGO! x-lite works through the Sagem F@st

    10. #29
      PmX's Avatar
      PmX
      PmX is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Mid/Everyday
      Router: Sagem F@ST 2504
      Sky TV: Sky Basic
      Join Date
      Oct 2009
      Posts
      1
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: VoIP with Sky/Sagem F@st 2504

      Quote Originally Posted by madkat View Post
      I had a brainwave.
      And I can't believe nobody else thought of it.
      Seriously.

      It occurred to me that the router configuration file is just a .conf file. Now these are usually plain text. In this case, it's XML.

      I opened the .conf file in Notepad++. You can use any editor you want.

      I was scanning through the various elements when I spotted a property called siproxd. WTF? What's that? It has "SIP" and "prox" in the name... Google came up with this: Siproxd Project

      So I changed the value from "enable" to "disable", saved the conf file and reimported it into the router.

      BINGO! x-lite works through the Sagem F@st
      This worked for me too! thanks! The only issue I have now is that I can hear the caller but they can't here me. Checked the mic setup and everything there is fine - i enabled all incoming ports and even set my computer as the DMZ plus machine, still no joy

     

     
    Page 3 of 3 FirstFirst 123

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION