Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Page 7 of 8 FirstFirst ... 5678 LastLast
    Results 61 to 70 of 75

    Problems loading some sites but not others?

    This is a discussion on Problems loading some sites but not others? within the Sky Broadband help forums, part of the Sky Broadband help and support category; I have investigated further and can shed some light on what is happening I noticed that when trying to load ...

    1. #61
      astronaut's Avatar
      astronaut is offline Sky User Member
      Exchange: St Neots
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Dec 2007
      Posts
      6
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Problems loading some sites but not others?

      I have investigated further and can shed some light on what is happening

      I noticed that when trying to load the news.bbc.co.uk site that the browser was stuck on newsimg.bbc.co.uk (this is where all the pictures are held)
      When using the Easynet DNS then the following happens

      G:\Program Files\Windows Resource Kits\Tools>tracert newsimg.bbc.co.uk

      Tracing route to newsimg.bbc.net.uk [212.58.226.75]
      over a maximum of 30 hops:

      1 <1 ms <1 ms <1 ms 192.168.0.1
      2 51 ms 47 ms 56 ms cr0.emstneo.uk.easynet.net [87.87.251.3]
      3 39 ms 39 ms 39 ms ip-87-87-156-33.easynet.co.uk [87.87.156.33]
      4 42 ms 41 ms 40 ms be2.er10.thlon.ov.easynet.net [195.66.224.43]
      5 41 ms 41 ms 41 ms bbc-gw0-linx.prt0.rbsov.bbc.co.uk [snip]
      6 41 ms 41 ms 40 ms 212.58.238.133
      7 41 ms 41 ms 41 ms 212.58.239.58
      8 42 ms 41 ms 41 ms newslb306.telhc.bbc.co.uk [212.58.226.75]

      However if I promote the OpenDNS server to be the primary DNS then it returns a different IP address and then the ping and tracert fails

      G:\Program Files\Windows Resource Kits\Tools>tracert newsimg.bbc.co.uk

      Tracing route to a1733.g.akamai.net [80.67.87.30]
      over a maximum of 30 hops:

      1 <1 ms <1 ms <1 ms 192.168.0.1
      2 44 ms 47 ms 43 ms cr0.emstneo.uk.easynet.net [87.87.251.3]
      3 39 ms 39 ms 39 ms ip-87-87-156-33.easynet.co.uk [87.87.156.33]
      4 41 ms 41 ms 41 ms be2.er10.thlon.ov.easynet.net [195.66.224.43]
      5 41 ms 40 ms 41 ms Gi3-0.lonth-inter-1.interoute.net [195.66.224.53
      ]
      6 41 ms 41 ms 41 ms Gi4-0.lon-wal-core-2.interoute.net [84.233.152.1
      85]
      7 41 ms 41 ms 41 ms Te4-1.lon-wal-access-3.interoute.net [217.118.11
      9.34]
      8 * * * Request timed out.

      Going to the OpenDNS cache and looking up newsimg.bbc.co.uk there, I get back 3 different IP addresses - all different from the one returned by easynet

      Results for newsimg.bbc.co.uk
      United States
      New York, New York, USA Palo Alto, California, USA

      * a1733.g.akamai.net
      * news.bbc.co.uk.edgesuite.net
      * newsimg.bbc.net.uk
      * 204.245.162.24
      * 204.245.162.26



      * a1733.g.akamai.net
      * news.bbc.co.uk.edgesuite.net
      * newsimg.bbc.net.uk
      * 128.241.220.80
      * 128.241.220.87

      Seattle, Washington, USA Washington, DC, USA

      * a1733.g.akamai.net
      * news.bbc.co.uk.edgesuite.net
      * newsimg.bbc.net.uk
      * 128.241.220.80
      * 128.241.220.87



      * a1733.g.akamai.net
      * news.bbc.co.uk.edgesuite.net
      * newsimg.bbc.net.uk
      * 204.245.162.24
      * 204.245.162.26

      Europe
      London, England, UK

      * a1733.g.akamai.net
      * news.bbc.co.uk.edgesuite.net
      * newsimg.bbc.net.uk
      * 80.67.87.30
      * 80.67.87.8

      Refreshing the OpenDNS cache made no difference

      I have also used various other DNS lookup tools and get a variety of addresses returned (presumably the bbc tries to distribute its pictures to a variety of sites to improve performance)

      So I can see a number of possibilities
      • the OpenDNS entry is simply wrong / out of date
      • the OpenDNS entry is OK but easynet routing to it is broken
      • the entry is valid but access is blocked for UK users


      I suspect something similar with ebay (when using OpenDNS I eventually got a page missing all images) - could it be that the bbc has a newsimg server in many European countries and OpenDNS is only returning one ?


    2. Advertisement
    3. #62
      James67's Avatar
      James67 is offline Sky User Member
      Exchange:
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Freesat
      Join Date
      Sep 2007
      Posts
      1,789
      Thanks
      0
      Thanked 2 Times in 2 Posts
      Blog Entries
      3

      Re: Problems loading some sites but not others?

      Quote Originally Posted by Saturday View Post
      Referesh the OpenDNS cache using the OpenDNS web facility and the problem URL now resolves.

      Yep, nothing to do with OpenDNS.
      Yeah, but think about it. Getting OpenDNS to refresh its cache for a particular domain name makes it go to the primary domain name server for that domain and reload the A record (IP address) information. Now if that ends up fixing the problem, what was OpenDNS doing before it was "fixed"? Returning a "not found" response? Returning incorrect A record information?

      Well, it couldn't have been a "not found" response because OpenDNS never returns such responses. If it can't resolve a domain name, it returns the IP address of one of its own servers, which then uses the HTTP/1.1 request header information to give a search page output. Well, clearly that's not happening, so that leaves the second possibility, that it's returning the wrong IP address.

      I don't know the ins-and-outs of OpenDNS's caching policies, but I'd imagine that they are more "aggressive" than a normal DNS server - otherwise why would they have a manual "refresh" facility? So maybe a particular site might have been upgrading to faster servers to cope with Christmas demand and had waited for the new A record information to propogate before switching off the old server. I can imagine that being a problem if OpenDNS do indeed "over-cache" information, and I can see how that could be resolved by triggering a refresh. Yeah, I can see that happening with one, or maybe even two sites, but whole swathes of the Internet changing their IP addresses. Honestly, I think that's unlikely.

      Maybe refreshing the OpenDNS cache has some other side-effect that resolves the problem, but I really can't think what that could be.

      When you look through this complete thread, there really is only one explanation that fits everything (or very nearly everything), and that is that it's a routing issue.

    4. #63
      moleman's Avatar
      moleman is offline Sky User Member
      Exchange: Hadleigh EAHAE
      Broadband ISP: Sky Broadband Unlimited
      Router: DG834GT + TL-WR702N
      Sky TV: Sky+HD box
      Join Date
      Sep 2006
      Posts
      825
      Thanks
      10
      Thanked 31 Times in 29 Posts

      Re: Problems loading some sites but not others?

      Quote Originally Posted by James67 View Post
      No-one's ever going to listen to anything I say, ever again, are they…
      I'll still trust you James (well mostly)

    5. #64
      Alan b's Avatar
      Alan b is offline Sky User Member
      Exchange:
      Broadband ISP: Unlimited
      Router: Netgear V1 DG834GT
      Sky TV: 2 x Sky+ HD
      Join Date
      Sep 2006
      Posts
      4,188
      Thanks
      18
      Thanked 56 Times in 52 Posts

      Re: Problems loading some sites but not others?

      To be honest james67 I couldn't careless what the problem is, if it is a OpenDNS problem or not I just want it fixed.

      The BBC website is fine for me as is Argos now and Photobucket is a liitle slow loading but it does load. It doesn't make any difference if I am using OpenDNS or not at the moment. That gaming site that was posted earlier doesn't load at all.

    6. #65
      James67's Avatar
      James67 is offline Sky User Member
      Exchange:
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Freesat
      Join Date
      Sep 2007
      Posts
      1,789
      Thanks
      0
      Thanked 2 Times in 2 Posts
      Blog Entries
      3

      Re: Problems loading some sites but not others?

      On the other hand, my arguments rely on the presumption that OpenDNS hasn't been totally foobar'd, and what astronaut just wrote suggests that that presumption isn't entitely valid!

      *checks for himself*

      Yup, OpenDNS is completely broken. It's returning a load of nonsense with many DNS requests.

      So I reckon the current problems can be summed up as being the product of three failures:
      1. Routing problems at some Easynet peers (ntt.net is one such case, but there may be others)
      2. Those routing issues are sometimes making it difficult to get through to OpenDNS, which many people use in preference to Easynet's own DNS servers
      3. When you do get through to OpenDNS, it's returning information which cannot be regarded as reliable


      Oh dear…

    7. #66
      Saturday's Avatar
      Saturday is offline Sky User Super Mod
      Exchange:
      Broadband ISP: Sky Broadband Unlimited Pro
      Router: Sky Hub SR102
      Sky TV: Sky+HD box
      Join Date
      Sep 2006
      Posts
      6,086
      Thanks
      20
      Thanked 52 Times in 47 Posts

      Re: Problems loading some sites but not others?

      Quote Originally Posted by astronaut View Post
      I noticed that when trying to load the news.bbc.co.uk site that the browser was stuck on newsimg.bbc.co.uk (this is where all the pictures are held)
      Yes that was the problem I was having with the problem sites e.g. us.i1.yimg.com


      Quote Originally Posted by astronaut View Post
      Going to the OpenDNS cache and looking up newsimg.bbc.co.uk there, I get back 3 different IP addresses - all different from the one returned by easynet
      Yes, same again.



      Quote Originally Posted by astronaut View Post
      Refreshing the OpenDNS cache made no difference
      Oh - when I refreshed the cache the addresses were updated to the same address rather than several. Presumably that's why the problem for that URL went away.

    8. #67
      lumoruk's Avatar
      lumoruk is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Broadband Unlimited
      Router: Netgear V1 DG834GT
      Sky TV: Sky+
      Join Date
      Dec 2007
      Location
      Near Oxford
      Posts
      38
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Problems loading some sites but not others?

      Hello, I'm new here so it's not my new Sagem router (1 month) that is at fault it's just Sky being crap?

    9. #68
      Alan b's Avatar
      Alan b is offline Sky User Member
      Exchange:
      Broadband ISP: Unlimited
      Router: Netgear V1 DG834GT
      Sky TV: 2 x Sky+ HD
      Join Date
      Sep 2006
      Posts
      4,188
      Thanks
      18
      Thanked 56 Times in 52 Posts

      Re: Problems loading some sites but not others?

      Quote Originally Posted by lumoruk View Post
      Hello, I'm new here so it's not my new Sagem router (1 month) that is at fault it's just Sky being crap?
      If you are having problems loading up sites such as ebay, bbc and the like then it is not your new router as there are some problems around the network. Quite what they are and when they are going to be sorted is anybodies guess.

    10. #69
      kindredknight's Avatar
      kindredknight is offline Sky User Member
      Exchange: YORK
      Broadband ISP: Max
      Router:
      Sky TV:
      Join Date
      Jul 2007
      Posts
      22
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Problems loading some sites but not others?

      Quote Originally Posted by Alan b View Post
      If you are having problems loading up sites such as ebay, bbc and the like then it is not your new router as there are some problems around the network. Quite what they are and when they are going to be sorted is anybodies guess.

      yeah typical when im trying to buy something on ebay lol....takes me 20min to get it to work , then cant pay for it by paypal as that wont let me in.

      come on sky pull your finger out.

      on the brightside my downloads and games work fine

    11. #70
      Saturday's Avatar
      Saturday is offline Sky User Super Mod
      Exchange:
      Broadband ISP: Sky Broadband Unlimited Pro
      Router: Sky Hub SR102
      Sky TV: Sky+HD box
      Join Date
      Sep 2006
      Posts
      6,086
      Thanks
      20
      Thanked 52 Times in 47 Posts

      Re: Problems loading some sites but not others?

      Quote Originally Posted by James67 View Post
      So I reckon the current problems can be summed up as being the product of three failures
      Which is what I've suggested several times in this thread

     

     
    Page 7 of 8 FirstFirst ... 5678 LastLast

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION