Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 8 of 8

    Opening ports

    This is a discussion on Opening ports within the Sky Broadband help forums, part of the Sky Broadband help and support category; Right. Im getting annoyed now. I have looked at tut's but it still dont work. I am needing to open ...

    1. #1
      Gass's Avatar
      Gass is offline Sky User Member
      Exchange:
      Broadband ISP: Base
      Router:
      Sky TV:
      Join Date
      Oct 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Opening ports

      Right. Im getting annoyed now.

      I have looked at tut's but it still dont work.

      I am needing to open ports 8000 + 80

      I need to open port 80 to run a shoutcast server and so people can connect throught my ip

      I dont no if i done it right on Services + firewall i put 192.168.0.2:8000 and i see the shoutcast page. i tell my mate to connect though a dj program and he says it says error.
      So i connect and it works for me (probaly because it is my ip) and i tell him to go on the site and see if he can hear music and he said no. but i can hear music so i asked other people and they cant (probaly again because its my ip)

      So basically how can i open port 8000 correctly so that people can connect thought my ip and can see my stuff.

      Because i dont no wot i send them is it 192.168.0.2
      or is it the ip that is like 90.83.4.34

      Please help i really need to open these ports correctly.

      If you can add me on msn lfc.liam@hotmail.com
      Thanks
      Liam


    2. Advertisement
    3. #2
      James67's Avatar
      James67 is offline Sky User Member
      Exchange:
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Freesat
      Join Date
      Sep 2007
      Posts
      1,789
      Thanks
      0
      Thanked 2 Times in 2 Posts
      Blog Entries
      3

      Re: Opening ports

      The 192.168.0.2 address is a private address. It can only be access on your own network, it can't be accessed directly from outside your own network.

      The port forwarding feature forwards requests to your external address (the 90.83.4.34 one) to the private address, so your friend will have to access it via that address. Note, however, that you won't be able to access it from that address because port forwarding only works for people on the public side of the router. Also be aware that the address will change whenever your router reconnects to Internet.

    4. #3
      Gass's Avatar
      Gass is offline Sky User Member
      Exchange:
      Broadband ISP: Base
      Router:
      Sky TV:
      Join Date
      Oct 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Opening ports

      Quote Originally Posted by James67 View Post
      The 192.168.0.2 address is a private address. It can only be access on your own network, it can't be accessed directly from outside your own network.

      The port forwarding feature forwards requests to your external address (the 90.83.4.34 one) to the private address, so your friend will have to access it via that address. Note, however, that you won't be able to access it from that address because port forwarding only works for people on the public side of the router. Also be aware that the address will change whenever your router reconnects to Internet.


      So how can i portforward then Basically open ports 8000?
      And make people connect.

      Because. i tryed on Firewall rules on the router settings

      I Put external ip 90.83.4.34 says illegal ip.

      And Anyway Half of the stuff Example Shoutcast = port 8000
      i do This

      90.197.0.30:8000 dont work
      192.168.0.2:800 and it works

      please help

    5. #4
      James67's Avatar
      James67 is offline Sky User Member
      Exchange:
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Freesat
      Join Date
      Sep 2007
      Posts
      1,789
      Thanks
      0
      Thanked 2 Times in 2 Posts
      Blog Entries
      3

      Re: Opening ports

      You have to give the router the private address you want connections to be forwared to, and people who want to connect have to use the public address. Also if you want to forward a port which isn't one of the standard services that the router knows about, then you need to define a service name first.

      So if you want TCP connections from outside on port 8000 to go to port 8000 on 192.168.0.2, you first go to the Services page on the router and define a service. Click on Add Custom Service and enter a name, say shoutcast, and enter a start and finish port number of 8000, then click on Apply.

      Then go to the Firewall Rules page and click on the Add button in the Inbound Services section. Select the shoutcast service, make sure action is "ALLOW always", enter the private address - i.e., 192.168.0.2 - where it says Send to LAN Server and make sure the WAN Users option says Any. Then click on Apply.

      Once you've done that, anyone outside your network will be able to connect to TCP port 8000 on your public address - i.e., the 90.x.x.x one - and the connection will be forwarded to your private address - 192.168.0.2.

    6. #5
      Gass's Avatar
      Gass is offline Sky User Member
      Exchange:
      Broadband ISP: Base
      Router:
      Sky TV:
      Join Date
      Oct 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Opening ports

      Quote Originally Posted by James67 View Post
      You have to give the router the private address you want connections to be forwared to, and people who want to connect have to use the public address. Also if you want to forward a port which isn't one of the standard services that the router knows about, then you need to define a service name first.

      So if you want TCP connections from outside on port 8000 to go to port 8000 on 192.168.0.2, you first go to the Services page on the router and define a service. Click on Add Custom Service and enter a name, say shoutcast, and enter a start and finish port number of 8000, then click on Apply.

      Then go to the Firewall Rules page and click on the Add button in the Inbound Services section. Select the shoutcast service, make sure action is "ALLOW always", enter the private address - i.e., 192.168.0.2 - where it says Send to LAN Server and make sure the WAN Users option says Any. Then click on Apply.

      Once you've done that, anyone outside your network will be able to connect to TCP port 8000 on your public address - i.e., the 90.x.x.x one - and the connection will be forwarded to your private address - 192.168.0.2.

      I have done that.

      but i dont think it works because shoutcast i give people the details 2 connect to dj 1st i give them 192.168.0.2

      He told me it never worked
      then i give him the 90.x.x.x and he said that didnt work

      So i Broadcasted

      I put 90.x.x.x.x didnt work i put 192.168.0.2 in worked
      i give the url 2 listen he couldnt hear anything only i could

      So basically i need 2 open the right ports :s but i dont no how.

      so people can connect.

      Could you remote controll my pc and fix it ? or make it like a tut

    7. #6
      James67's Avatar
      James67 is offline Sky User Member
      Exchange:
      Broadband ISP: Other ISP
      Router: Non Sky Router
      Sky TV: Freesat
      Join Date
      Sep 2007
      Posts
      1,789
      Thanks
      0
      Thanked 2 Times in 2 Posts
      Blog Entries
      3

      Re: Opening ports

      It's more likely to be a shoutcast issue then, because those are the right instructions for making port forwarding work. I'm not familiar with shoutcast, so I can't really help with that.

      But you do have to remember that your public address - the 90.x.x.x one - is liable to change. A different address is allocated each time the router connects to the Internet.

      Try googling for support information on using shoutcast. There's bound to have been people in the same situation as yourself who have worked out what you need to do to get this to work.

    8. #7
      IWasNotTheEnemy's Avatar
      IWasNotTheEnemy is offline Sky User Member
      Exchange: LWWIL
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Hub SR102
      Sky TV: Now TV
      Join Date
      Apr 2007
      Location
      London
      Posts
      9,374
      Thanks
      3
      Thanked 122 Times in 121 Posts

      Re: Opening ports

      best thing is set ur PC (192.168.0.2 for example) as a DMZ and then all you have to do it give the listeners outside ur network the external IP address (90.x.x.x:8000/listen.pls for example) and it should work...

      I used to use ShoutCAST a lot so i'll try and work it out but my PC is a DMZ so i have all net traffic open to my PC
      -------------------------------------------



      Useful Sticky: - How To Obtain Your Router Stats, BT Speed Test, Check For Test Socket

    9. #8
      Gass's Avatar
      Gass is offline Sky User Member
      Exchange:
      Broadband ISP: Base
      Router:
      Sky TV:
      Join Date
      Oct 2007
      Posts
      8
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Opening ports

      I dont get that?

     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION