in ur settings in the router make sure the Port Scan protection is disabled and the tcp flood and udp flood are disabled also ,enabling these will prevent huge searches in dc