Your forum username:
Do you already have an account?
Forgot your password?
  • Log in or Sign up


    Welcome to Sky User - The Unofficial Support Forum for everything Sky! - Proudly helping over 65k members.


    Advertisement

    Results 1 to 4 of 4
    Like Tree1Likes
    • 1 Post By speedyuk

    Using Cisco router with Sky VDSL connection

    This is a discussion on Using Cisco router with Sky VDSL connection within the Asking for help forums, part of the Broadband Technical Help category; Hi all, So I have been browsing the internet and cannot find any resources to assist me with setting up ...

    1. #1
      maxevaaans's Avatar
      maxevaaans is offline Sky User Member
      Exchange:
      Broadband ISP: Not applicable
      Router: Sky Q Hub ER110
      Sky TV: Sky Basic
      Join Date
      Jan 2018
      Posts
      4
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Using Cisco router with Sky VDSL connection

      Hi all,

      So I have been browsing the internet and cannot find any resources to assist me with setting up a Cisco with Sky's VDSL connection.

      When looking on my Sky HUBs status I can see that its network type is MER (which I assume uses MAC addresses to authenticate) however when I do a Wireshark capture I can see the router sending out PPP user and password which I have kept to one side.

      It would be really helpful if someone could explain how Sky's network authenticates and assigns public IP's and if possible recommend a Cisco router and configuration to use for this to work, and yes I understand this breaks T&C's


    2. Advertisement
    3. #2
      Scubbie's Avatar
      Scubbie is offline Sky User Moderator
      Exchange: 02392
      Broadband ISP: Sky Fibre Unlimited
      Router: Sky Q Hub ER110
      Sky TV: Sky+HD box
      Join Date
      Mar 2010
      Location
      Near Portsmouth
      Posts
      28,042
      Thanks
      827
      Thanked 2,202 Times in 2,072 Posts

      Re: Using Cisco router with Sky VDSL connection

      Not all routers natively support Sky's method for them to log into their servers.

      If the Cisco router you have doesn't have the Opt.61 setting available, then you'll need to investigate custom firmwares.

      Sky Fibre Unlimited Pro: Connected at 80,000 kbps / 20,000 kbps
      Previous ADSL2+ Speed 19999 kbps 1153 kbps, Line Attenuation 17.5 db 6.9 db, Noise Margin 7.5 dB 8.7 dB
      Speedtest: 17.15MB/s 0.97Mb/s Ping 31 ms

    4. #3
      speedyuk's Avatar
      speedyuk is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Fibre Unlimited
      Router: Cisco 867VAE-K9
      Sky TV: Sky Basic
      Join Date
      Jan 2018
      Posts
      6
      Thanks
      0
      Thanked 0 Times in 0 Posts

      Re: Using Cisco router with Sky VDSL connection

      Hi, In the spirit of helping others so hopefully someone can help me with getting IPv6 working here are the settings I've just used to get my 867VAE connected with IPv4. I've changed the default LAN IP addressing to 192.168.0.0/24 to match how the Sky Router is configured. I've used XXXX to cover up router specific info. You can obtain this info by using Wireshark to sniff DHCP requests sent out of Sky hub lan ports when it boots. From what I've read Sky don't check this info now, but no harm in entering it correctly just in case.

      Hope this helps

      version 15.4
      no service pad
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname Cisco867
      !
      boot-start-marker
      boot system flash c860vae-advsecurityk9-mz.154-3.M8.bin
      boot config usbflash0:CVO-BOOT.CFG
      boot-end-marker
      !
      !
      logging buffered 51200 warnings
      !
      no aaa new-model
      wan mode dsl
      !
      !
      !
      !
      !
      ip dhcp excluded-address 192.168.0.1
      !
      ip dhcp pool cvo-pool
      import all
      network 192.168.0.0 255.255.255.0
      default-router 192.168.0.1
      lease 0 2
      !
      !
      !
      ip inspect name DEFAULT100 ftp
      ip inspect name DEFAULT100 h323
      ip inspect name DEFAULT100 icmp
      ip inspect name DEFAULT100 rcmd
      ip inspect name DEFAULT100 realaudio
      ip inspect name DEFAULT100 rtsp
      ip inspect name DEFAULT100 esmtp
      ip inspect name DEFAULT100 sqlnet
      ip inspect name DEFAULT100 streamworks
      ip inspect name DEFAULT100 tftp
      ip inspect name DEFAULT100 tcp
      ip inspect name DEFAULT100 udp
      ip inspect name DEFAULT100 vdolive
      no ip domain lookup
      ip domain name yourdomain.com
      ip cef
      !
      !


      !
      !
      username cisco privilege 15 secret 5 $xxxxxxxxxxxxxxxxxxxxxxxx
      !
      !
      controller VDSL 0
      no cdp run
      !
      !


      !
      !
      interface ATM0
      no ip address
      shutdown
      no atm ilmi-keepalive
      cdp enable
      !
      interface Ethernet0
      mac-address 90xx.06xx.c5xx
      no ip address
      ip nat outside
      ip virtual-reassembly in
      !
      interface Ethernet0.101
      encapsulation dot1Q 101
      ip dhcp client request classless-static-route
      ip dhcp client client-id hex 3Cxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx xxxxxxxxxxxxx
      ip dhcp client hostname xxxxxxxxxxxx@skydsl|xxxxxxxx
      ip address dhcp
      no ip redirects
      no ip proxy-arp
      ip flow ingress
      ip flow egress
      ip nat outside
      no ip virtual-reassembly in
      no cdp enable
      !
      interface FastEthernet0
      no ip address
      spanning-tree portfast
      !
      interface FastEthernet1
      no ip address
      spanning-tree portfast
      !
      interface FastEthernet2
      no ip address
      spanning-tree portfast
      !
      interface FastEthernet3
      no ip address
      spanning-tree portfast
      !
      interface GigabitEthernet0
      no ip address
      !
      interface GigabitEthernet1
      description $ES_WAN$$FW_OUTSIDE$
      no ip address
      shutdown
      duplex auto
      speed auto
      !
      interface Vlan1
      description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
      ip address 192.168.0.1 255.255.255.0
      ip access-group 100 in
      ip flow ingress
      ip flow egress
      ip nat inside
      ip virtual-reassembly in
      ip tcp adjust-mss 1452
      !


      !
      ip forward-protocol nd
      ip http server
      ip http access-class 23
      ip http authentication local
      ip http secure-server
      ip http timeout-policy idle 60 life 86400 requests 10000
      !
      !
      ip nat inside source list 1 interface Ethernet0.101 overload
      !
      mac-address-table aging-time 10
      !
      access-list 1 permit 192.168.0.0 0.0.0.255
      access-list 23 permit 192.168.0.0 0.0.0.255
      access-list 100 deny ip host 255.255.255.255 any
      access-list 100 deny ip 127.0.0.0 0.255.255.255 any
      access-list 100 permit ip any any
      access-list 101 permit udp any eq bootps any eq bootpc
      access-list 101 deny ip 10.10.10.0 0.0.0.255 any
      access-list 101 permit icmp any any echo-reply
      access-list 101 permit icmp any any time-exceeded
      access-list 101 permit icmp any any unreachable
      access-list 101 deny ip 10.0.0.0 0.255.255.255 any
      access-list 101 deny ip 172.16.0.0 0.15.255.255 any
      access-list 101 deny ip 192.168.0.0 0.0.255.255 any
      access-list 101 deny ip 127.0.0.0 0.255.255.255 any
      access-list 101 deny ip host 255.255.255.255 any
      access-list 101 deny ip any any
      !
      !
      line con 0
      login local
      no modem enable
      line aux 0
      line vty 0 4
      access-class 23 in
      privilege level 15
      login local
      transport input telnet ssh
      !
      scheduler allocate 60000 1000
      !
      end
      Scubbie likes this.

    5. #4
      skyeci's Avatar
      skyeci is offline Sky User Member
      Exchange:
      Broadband ISP: Sky Fibre Unlimited Pro
      Router: ECI CAB - Billion 8800NL V1(bridge mode) + i5 Qotom OPNSense with IPV6
      Sky TV: Sky+HD box
      Join Date
      May 2015
      Posts
      527
      Thanks
      10
      Thanked 34 Times in 34 Posts

      Re: Using Cisco router with Sky VDSL connection

      both pfsense and Opnsense will work with sky's ipv6 - have used both with no issues. thanks to marjohn56 of course for making it all happen

      I posted some settings info in another post that might help you
      Billion 8800NL modem (bridge mode)
      Qotom i5 Opnsense with IPV6
      Asus RT-AC88U - as wap

      ECI CAB- G.INP disabled 8th April 2016

      click for my ECI line stats

      click for line stats by Pi3/Huawei

      **SOON TO BE FTTP! **


     

     

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    SkyUser - Copyright © 2006-2017. SatDish and NewsreadeR | SkyUser is in no way affiliated with Sky Broadband / BSkyB
    RIPA NOTICE: NO CONSENT IS GIVEN FOR INTERCEPTION OF PAGE TRANSMISSION